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Exam : IBM 000-286

Title : Test286,applecation development wwebsphere studio,v5.0

1. When creating a Web Project in WebSphere Studio, the initial set of files will be created in either:

A. The repository

B. The deployment directory of the application server

C. A WebSphere Studio determined directory

D. A developer specified directory

E. The root directory as specified by the J2EE(TM) spec

Answer: CD

2. A developer is given a J2EE EAR file that contains source and wants to develop and test the application. Which of 

the following tasks MUST be performed to import this J2EE application into WebSphere Studio?

A. Use the EAR Import utility to create the Enterprise Application Project and contained module project(s) directly 

from the EAR file.

B. Use the Create Enterprise Application Project Wizard to create the J2EE projects within WebSphere Studio and 

import those modules from the EAR file.

C. Use the Create Web Project Wizard to create a Web project within WebSphere Studio and then use the EAR 

import utility to populate the Web project.

D. Use the WAR import utility to create a Web project and the containing Enterprise Application Project and populate 

each from the EAR file.

Answer: A

3. A consultant working on projects from different clients needs to be able to completely separate each client's 

projects. What is the BEST way to accomplish this using WebSphere Studio?

A. Name the projects with a scheme that distinguishes them from each other.

B. Load multiple projects at the same time into the workspace and configure each with a unique name.

C. Have a separate workspace for each client's projects in the file system.

D. Use options under the File menu to load the desired project.

Answer: C

4. The search function of a class in the Outline view can be used to locate:

A. Types in Workspace using search expressions.

B. Declarations in Workspace regardless of package.

C. References in Workspace regardless of package.

D. References to errors in selected resource.

Answer: BC

5. To add a newly created project to the team's version control management system, a developer must:

A. Export the Local History to the remote repository.
B. Right-click on the project and select Team -> Share Project. 

C. Select the appropriate version control management system in the project's properties.

D. Select Add to Version Control in the Project menu.

Answer: B

  

    
      

      

      

      

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 
  

 

 

   

 

 

 

 

 

 

 

      

 

 

 

 

 

 
    

   

 
    

 

 

  

 

 

 
    

    

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

      

      

        

      

      

      

      

      

      

      

        

      

      

      

      

      

      

      

      

      

   

 

                                

                                

                



      

            

      

     

     

  

  

 

       

     

 

   

 
     

 

         

 

 

 

 

 

   

   

     

     

   
 

  

   

      

   

   

      

   

  

 

   

   

 

   

     

 

     

 
  

  

     

   

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
      

 

 

 

6. Which accurately describes the steps for adding the import statement for ClassZ? ClassZ is in a different package. 

package packageA; public class ClassX { ClassZ classZ = new ClassZ(); }
A. Right-click anywhere in the source and choose Source-->Add Import. 

B. Select "ClassZ", right-click, and choose Source-->Add Import. 

C. Select the filename in Package Explorer, right-click, and choose Source-->Add Import. 

D. Select the entire line that references ClassZ, right-click, and choose Source-->Add Import. 

Answer: B

7. Which of the following are TRUE about the Compare and Replace functions in regard to the local history?

A. They both list the dates and times that the files were last saved.

B. They can operate on different filenames.

C. They can operate on more than two files.

D. They only operate on files in the workspace.

E. They can operate on files at a remote location.

Answer: AD

8. Why would a developer use the Extract Method wizard?

A. To remove a method from one class and place it in another, to better distribute responsibilities

B. To remove a method and all of the references to it, since it is no longer needed

C. To move a selected part of a method to a new method and replace the original code with a call to that new method

D. To retrieve a method from a JAR file

Answer: C

9. ClassA in Example A below is opened in the Hierarchy view. Show Type Hierarchy and Show All Inherited 

Members are both turned on.

Example A:

package myPackage;

public class ClassA implements InterfaceX{

public static void main(String[] args){

}

protected class ClassC {

public int returnTwo(long x){

return 2;

}

}

private static int returnOne(long x){

return 1;

}

Example B:

package myPackage;

public interface InterfaceX {

public static final String x = "yo";

}

Which of the following references to elements of the source files MAY be displayed along with ClassA?

A. returnOne(long)

B. returnTwo(long)

C. x

D. InterfaceX

E. ClassC

Answer: AC

10. How does a developer manage the build path of a Java Project?

A. The build path is set from the context menu of a project in the J2EE Navigator view

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 
  

 

 

   

 

 

 

 

 

 

 

      

 

 

 

 

 

 
    

   

 
    

 

 

  

 

 

 
    

    

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

      

      

        

      

      

      

      

      

      

      

        

      

      

      

      

      

      

      

      

      

   

 

                                

                                

                



      

            

      

     

     

  

  

 

       

     

 

   

 
     

 

         

 

 

 

 

 

   

   

     

     

   
 

  

   

      

   

   

      

   

  

 

   

   

 

   

     

 

     

 
  

  

     

   

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
      

 

 

 

  

    
      

      

      

      

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

B. The build path is set in the Build Path page on the properties dialog of a project

C. The build path is determined by the source folders set up within a project and through the import statements in the 

code

D. The build path is set only when the project is created or when new packages are added to it

Answer: B

11. When creating a new Java Project using the wizard, what is the principal function of the "Projects" tab?

A. To name the project and specify its source folders

B. To add existing projects to the new project's Java Build Path

C. To include additional Jar files if the new project requires additional libraries

D. To view and import projects located in a team repository

Answer: B

12. While creating a new Java Project, there is a large external JAR file that this project and other projects are going 

to need to add to their build paths. The BEST way to make this JAR file available to all projects would be to:

A. Add the external JAR file to each of the projects.

B. Create a classpath variable that refers to the external JAR and add it to each project's build path.

C. Import the external JAR file into this project and then add this project to all the other projects' build path.
D. Import the external JAR into one of other projects and add that project to the build path while creating this project. 

E. Import the external JAR file into each of the projects.

Answer: B

13. The "Errors and Warnings" section of the Java-->Compiler preferences page allows a developer to select the 

severity level of the following problems:

A. Unreachable code

B. Non terminated strings

C. Unresolvable import statements

D. Non initialized instance variables

E. Unused imports

Answer: ACE

14. To change a JUnit test and re-run it without having to re-run the entire suite, the following need to be done: 

A. Run in debug mode

B. Enable checkbox on Launch Configuration page to keep JUnit running after a test

C. Configure the test to run on the server

D. Select option on Debug Preference page to keep JUnit running after a test

Answer: AB

15. How is the priority of a Task set?
A. Double-click a Task to launch the Tasks Property dialog and choose the priority from the "Priority" dropdown list. 

B. Right-click a Task and select Properties to launch the Tasks Property dialog and choose the priority from the 

"Priority" dropdown list.
C. Right-click a Task and select Set Priority and then High, Normal, or Low. 

D. Click the "!" column of a Task and select High, Normal, or Low from the dropdown list.

Answer: D

16. A developer wishes to customize the Web Perspective to add the toolbar button for launching Java applications. 

Which of the following tasks MUST the developer perform to add this button to the toolbar?

A. Open a perspective which has this button in the toolbar in a new window, and drag it into the Web Perspective's 

toolbar.
B. Select Window -> Customize Perspective and select Launch from the list of Action Sets. 

C. Right-click on the Web Perspective's toolbar and select the Launch option from the context menu. 

D. Select Window -> Preferences and select the "Show launch buttons in other perspectives" checkbox from the Java 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

      

      

        

      

      

      

      

      

      

      

        

      

      

      

      

      

      

      

      

      

   

 

                                

                                

                



      

            

      

     

     

  

  

 

       

     

 

   

 
     

 

         

 

 

 

 

 

   

   

     

     

   
 

  

   

      

   

   

      

   

  

 

   

   

 

   

     

 

     

 
  

  

     

   

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
      

 

 

 

  

    
      

      

      

      

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 
  

 

 

   

 

 

 

 

 

 

 

      

 

 

 

 

 

 
    

   

 
    

 

 

  

 

 

 
    

    

   

section.

Answer: B

17. A developer needs to create a set of complex SQL statements. Which of the following tools would BEST serve 

this purpose?

A. SQL scripter

B. SQL editor

C. SQL query builder

D. SQL structure builder

Answer: C

18. While writing JDBC code in a Java Project, a developer needs to see the schema (metadata) for a database. What 

is the minimum set of tasks which MUST be accomplished in WebSphere Studio to meet this need?

A. Start the data connector agent.

B. Create a data object filter

C. Create a connection to the database.

D. Open up tables of interest in DB Servers view.

E. Import the schema to Java Project folder.

Answer: CD

19. The Java Editor code assist facility does the following by default:

A. Automatically inserts single proposals

B. Shows only proposals visible in the invocation context

C. Hides Javadoc information associated with proposal selected in list

D. Fills argument name on method completion

E. Automatically adds qualified name instead of import statement

Answer: AB

20. Which of the following may be displayed in the Outline view in the Java perspective?

A. Packages

B. Private methods

C. Errors

D. Field members declared within a class

E. Variables declared within methods

Answer: ABD
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